Missing Authserver.exe in ..build/bin folder

Hello, first time installer here. I’ve followed all steps and have been successful so far, up until running the code on microsoft visual studio.

Following the guide, this is where I'm not lining up / am stuck at now. I've 19 / 3 / 0/ 0. 

========== Build: 22 succeeded, 0 failed, 0 up-to-date, 1 skipped ==========


There appears to be some sort of issue with visual studio "cannot input file ..\database\release\database.lib

Cmake had no issues generating + configuring. I'm clearly missing the worldserver.exe / a few other files in the ...build/bin/release folder.

Could anyone please help me out? Not sure how to fix this.


ive had this problem compilling ashamane core few days ago, ive solved it by downloading last version of VS and Cmake, sonunds stupid but worked for me

capture : https://ibb.co/gvTSze

vs log https://pastebin.com/V2pUtnpg

cmake log https://pastebin.com/uy1uSrQU

mysql 8 not supported yet:



MySQL ≥ 5.1.0 up to MySQL 5.7.x

Thank you gentlemen for the assistance! Never would’ve guessed that was the matter.

I fixed MYSQL and got the 5.6 version (accidentally got 8.0 previously). Reinstalled the entire Core + Build and everything worked without error.

Now I'm missing the authserver.exe files (trying to do 3.3.5a). Everything else is in there. I tried searching the forums for any similar issue but couldn't find anything. I've no idea why it is missing if everything else worked flawlessly. However, I do notice the last line on VS says "build 26 successful"; the installation guide says the number should be 22. No idea if that's relevant,

I for certain selected the 3.3.5 branch from github: [https://github.com/TrinityCore/TrinityCore/tree/3.3.5](https://github.com/TrinityCore/TrinityCore/tree/3.3.5) 

Can any beautiful person lend a hand? I appreciate it greatly!


Edit 1*: It seems like somehow the legion client got installed even though I specifically copied the 3.3.5 link into gitclone. Weird. Reattempting again with a fresh install.

Edit 2*: Did a fresh reinstall using this github link: https://github.com/TrinityCore/TrinityCore.git - it still downloaded the legion client. What the hell? Can someone provide the correct github source link to clone the files from? How do I get it to install the WOTLK version? I’m going bonkers over this lol.

If you’re cloning from the url in the drop-down, you’ll always get all branches. Just use git to select the 3.3.5 branch. At a linux shell, it would be, “git checkout 3.3.5”, as I recall. You could also clone a specific branch with, “git clone -b 3.3.5 https://github.com/TrinityCore/TrinityCore.git” Or you could just download the branch directly from https://github.com/TrinityCore/TrinityCore/archive/3.3.5.zip, unzip it, and go to town.

I quite literally just did this on my own, I was going to update this saying so. Thank you though! I got it working.