Q: The Angry Gorloc

Hi everyone,

I tried fixing this Quest:


I thought of having an AreaTrigger with an SAI:

SET @ENTRY := 80000;


-- define Trigger

INSERT INTO `creature_template` (`entry`, `difficulty_entry_1`, `difficulty_entry_2`, `difficulty_entry_3`, `KillCredit1`, `KillCredit2`, `modelid1`, `modelid2`, `modelid3`, `modelid4`, `name`, `subname`, `IconName`, `gossip_menu_id`, `minlevel`, `maxlevel`, `exp`, `faction_A`, `faction_H`, `npcflag`, `speed_walk`, `speed_run`, `scale`, `rank`, `mindmg`, `maxdmg`, `dmgschool`, `attackpower`, `dmg_multiplier`, `baseattacktime`, `rangeattacktime`, `unit_class`, `unit_flags`, `dynamicflags`, `family`, `trainer_type`, `trainer_spell`, `trainer_class`, `trainer_race`, `minrangedmg`, `maxrangedmg`, `rangedattackpower`, `type`, `type_flags`, `lootid`, `pickpocketloot`, `skinloot`, `resistance1`, `resistance2`, `resistance3`, `resistance4`, `resistance5`, `resistance6`, `spell1`, `spell2`, `spell3`, `spell4`, `spell5`, `spell6`, `spell7`, `spell8`, `PetSpellDataId`, `VehicleId`, `mingold`, `maxgold`, `AIName`, `MovementType`, `InhabitType`, `Health_mod`, `Mana_mod`, `Armor_mod`, `RacialLeader`, `questItem1`, `questItem2`, `questItem3`, `questItem4`, `questItem5`, `questItem6`, `movementId`, `RegenHealth`, `equipment_id`, `mechanic_immune_mask`, `flags_extra`, `ScriptName`, `WDBVerified`) VALUES

(@ENTRY, 0, 0, 0, 0, 0, 11686, 16925, 0, 0, 'Mosswalker Village Trigger', '', '', 0, 60, 60, 0, 35, 35, 0, 1, 0.99206, 1, 0, 2, 2, 0, 24, 1, 2000, 0, 1, 33555200, 8, 0, 0, 0, 0, 0, 1, 1, 0, 10, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 'SmartAI', 0, 7, 1.35, 1, 1, 0, 0, 0, 0, 0, 0, 0, 0, 1, 0, 0, 128, '', 12340);

-- spawn Trigger

INSERT INTO `creature` (`guid`, `id`, `map`, `spawnMask`, `phaseMask`, `modelid`, `equipment_id`, `position_x`, `position_y`, `position_z`, `orientation`, `spawntimesecs`, `spawndist`, `currentwaypoint`, `curhealth`, `curmana`, `MovementType`, `npcflag`, `unit_flags`, `dynamicflags`) VALUES

(5137000, @ENTRY, 571, 1, 1, 0, 0, 5807.44, 3650.69, -14.4535, 1.62747, 300, 0, 0, 4120, 0, 0, 0, 0, 0);

-- SAI

INSERT INTO `smart_scripts` (`entryorguid`,`source_type`,`id`,`link`,`event_type`,`event_phase_mask`,`event_chance`,`event_flags`,`event_param1`,`event_param2`,`event_param3`,`event_param4`,`action_type`,`action_param1`,`action_param2`,`action_param3`,`action_param4`,`action_param5`,`action_param6`,`target_type`,`target_param1`,`target_param2`,`target_param3`,`target_x`,`target_y`,`target_z`,`target_o`,`comment`) VALUES

(@ENTRY*10,@SOURCETYPE,0,0,1,0,100,0,0,0,0,0,15,12578,0,0,0,0,0,17,0,50,0,0.0,0.0,0.0,0.0,"On Trigger - Quest Explored");

This seems to work fine, but when i restart my server, the trigger is gone…

Any idear why this happens?

Maybe phasemask? Weren’t areatriggers requiring sourcetype 2 btw? I

whell, i cannot invent a new AreaTrigger, because they are from a DBC. But i used a NPC, which acts the same way…

Oke i just sensed, that i had to rerun the script. The trigger works now, even after restart… Somehow its invisible (even with GM on) but i can live with that /emoticons/default_wink.png

I will test it tomorrow with different chars und some more restarts.

A custom creature is hack.

This should fix it blizzlike, but seems the spell has some crazy condition that I can’t find?

[CODE]DELETE FROM spell_area WHERE spell=54057;
INSERT INTO spell_area (spell, area, quest_start, quest_start_active, quest_end, aura_spell, racemask, gender, autocast) VALUES
(54057, 4297, 12578, 1, 12578, 0, 0, 2, 1);[/sql]

Seems the spell got some wrong conditions, but I can’t find these spells in conditions tables.

After all the damned spell has wrong zone… I quit on that if want try to find what is making this spell to require other zone I can’t.


hmm, oke thx for the info.

The spells works fine for me? I don’t sense any wrong condition…

Nvm, I had problems in my database, now fixed and quest working with it.

DELETE FROM `spell_area` WHERE `spell`=54057; INSERT INTO `spell_area` (`spell`, `area`, `quest_start`, `quest_start_active`, `quest_end`, `aura_spell`, `racemask`, `gender`, `autocast`) VALUES (54057, 4297, 12578, 1, 12578, 0, 0, 2, 1);[/sql]

What problems? Because i seem to have them now /emoticons/default_wink.png

Is there some sort of condition for the spell?

Well it seems I did complete this quest with my toon and had zone problems when tried to use any of this spells, then I tried with char that didn’t do it and there were none. The problem was that I was stupid enough to not remember I clicked complete before. As for the conditions not sure, but this works on other places too. Will check when I come back home tonight.

I have a problem, that the spell doesn’t work

When i do .aura 54057 i don’t get the credit and, after checking with .list aura, i obviously don’t get the spell…

Are you doing this on a char that has the quest active for first time?

P.S.: I tested it on latest core and it works exactly as it should /on clean core/. Though I state again the problem exactly that you describe I faced when completed this quest or dunno I think this was the reason, tried all you describe and had no effect. Also if you self cast this on yourself even on clean core nothing happens for some reason, but with spell area it works, then I tried on different character and it was fine. As for the aura I didn’t check it, but I check the quest itself. I suggest to try on diff char, if the result is positive it is somehow bugged in the time you tried to fix it for first time.

P.S.: I checked conditions and there are none, which means it self restrict in spell.dbc, also checked quest_template it use outside event which we are currently using, so the mechanic should be fine. Tested it on 3 more chars and works, also tested to cast it on myself and in that case it doesn’t give credit, which means most likely there is something outside of quest_template that check for spell_area cast of this spell and triggers a credit somehow. Recently I faced a lot of such crazy quests that have unexplainable mechanic to our database.

hmm… i testet it with one char that has done the questline untill the quest, one without an quest there… both no credit.

But i just don’t get the fact, that i didn’t anything different then restarting the server. no change in core, no update, just a restart^^

Oke, i will do a core-update and check it then…

Still doesn’t work… I found out, that there are conditions, because when i did this quest without having any quests of the chain done (via . quest add) i get the credit, but with the chain done so far, it doesn’t work…

Bah, I’ve written a lot, but deleted all as I usualy do, anyway the point is this, thanks to you I realised this area has 2 phases, it seems when player do the chain he goes on another. Now I don’t know the mechanic here, but will be best if there is another id for phase 2 of the village, if there is none the solution with areaid will be not usable. Thanks, for testing btw, never would think about this. Will, check it somewhere in this week, if noone else does, but I don’t remember such area saddly, hope I’m wrong. /if blizzard have any logic there should be one though/.

could be, or the Spell doesn’t like the Aura, that makes you friendliy with the Gorlocs… Because up to the Quest where you should kill one of them, the quest works…

Btw, when speaking of auras, it seems you are right again, 51644 - maybe this is connected - this is the aura.

Do you have any idea what is the change of player auras in that quest and after? If it is only that spell, can you provide the id. I’m going to sleep, will test it out tomorrow, you pretty much solved it. I checked the area and there is only 1 id, maybe under certain aura the village change to phase 2 and the core can’t recognize this as the real area.

As of the aura you speak of I think it is the only condition under which the spells we talk about can be casted, I remember having problem to cast it, but the area had no problems to forcecast it upon me. So maybe I was missing auras or smth.

Oke, after Core-Update it seems to work again.

xD /emoticons/default_biggrin.png Good to hear, I totaly got consumed in some events and couldn’t think what could it be.