[SOLVED]Authserver issue.

Hello all, I’m currently attempting to install 3.3.5a server. Everything is peachy so far, however I have ran into a snag, my authserver.exe seem to refuse to run and I’m not sure what issue is because I’ve ran it though debug several times and I don’t really see any crashing issues. Just bunch of stuff missing custom NPCs and whatnot missing, I don’t think those would be causing the issue. So do any of you have any idea why this might be happening (oh and all of my ports are open) also…

My worldserver seem to be running perfectly fine. Just authserver is having a bitch fit. I’m new to these forums sorry if I posted it in wrong place.


Did more tinkering, like reuploading trinityauth table and running it though debug again (for umpteenth time) still no luck. I would provide screenshots but there is literally no errors.

See if there is any .log file, any crash .txt and try to execute authserver from the console.

There’s nothing in Crashes or Logs files, also I tried as you suggested to execute authserver from the console, it still auto-closes. Only thing I really can provide is my authserver.config at this moment of time… Which is linked below in Pastebin:

http://pastebin.com/mqPz0ZRy (authserver) (password is obviously omitted)

Quite frustrating really.

Is worldserver running properly, just not authserver?

You say “auto-closes” so I’m assuming you are running Windows? Try opening a console (cmd.exe), then running it while not laucnhing the binary from Windows Explorer.

It won’t auto close, and should display an error, like, “can’t connect to the db, etc…”

Worldserver is running properly. Doesn’t close at all and functioning as it should, I’ve even created new account on it so it works. Just only Authserver that’s having a fit.

Also you do mean like RUN? If so, I did go into it and went to my file location and typed “start authserver” but it autocloses soon as the command is executed. Inside the folder where authserver is, there’s debug app that does that, I’ve ran it but nothing seems to be wrong, like no error message (other than some entries not being in tables and those minor stuff). I did receive a error about ports but after I opened it, it didn’t display any errors since then…Earlier though I did have some database connection issues but again, it’s fixed although I did find it weird that even though I changed account name to admin1 to specific IP, it still referenced to my old account Danare, so I had to recreate it to get it working but other than that, I have no idea why it would be closing.

without start, simply authserver.

OH! Now it does show error! It says: authserver.conf verify that file exists and have [authserver] written in on the top of the file!

But weird part as I linked the config above, it already has it in it… Should I create new text file, copypaste and make it config and replace the one I have in my file directory

EDIT: OH! I FIXED IT! Turns out my auth file was indeed fucked up. authserver config setting WAS supposed to be on top but for some reason realmid stuff was on top first now it’s fixed. ^^ Without ya’ll help I wouldn’t have been able to figure out! THANK YOU ALL!

— Canned message start —
It appears the issue in the original post was solved, so this thread shall be closed.
Should you encounter any other difficulties, please open a new thread.
— Canned message end —