[SOLVED]Change .Conf location

Hello i been trying to figure out how to change all my .dist and .conf file locations to lets say /server/conf how would one do this?

first off, are you on windows or linux?

on linux, i think you define


	to whatever directory you want them to be built in. ref: [https://trinitycore.atlassian.net/wiki/spaces/tc/pages/10977309/Linux+Core+Installation](https://trinitycore.atlassian.net/wiki/spaces/tc/pages/10977309/Linux+Core+Installation)

pretty sure in windows, you just change the location of the same cmake flag

Windows and will try it now thanks.

Ok in cmake i have Install_PREFIX don’t see a CONF_DIR or anything of the sort.


what happens if you check the advanced checkbox? Sorry, I dont have a windows box

Yeah don’t seem to be in there also possibly needs to be configured in the source with windows? Unsure where it would be in there not much of a coder but can edit

you can use cmake on command line on windows to use the change etc path.

And how would i be able to do this? only know the basics of cmake for compiling

Presumably, it works a lot like the linux version of the install. However, for more general information on using cmake in windows, you might look at this tutorial, which was the clearest answer I could find. (I haven’t used windows in over a decade, so it seems very confusing to me.)

Yeah still confused my self on how i would change the directories for config / data files

Look at oXL0C0Xo’s post above. That flag changes the config directory. You’ll also see it in the drop-down under the linux core installation. The cmake command ought to be roughly the same, so something like

cmake … -G “Visual Studio 15 2017” -DCMAKE_INSTALL_PREFIX=[install dir] -DCONF_DIR=[config dir] -DTOOLS=1

should get you a visual studio solution file which you use to compile (according to the tutorial). I

I have added those strings and fully compiled but World server and Auth Server are still unable to read config files from folder of choice.

Says Error: invalid or missing default configuration file

cmake … -G “Visual Studio 15 2017 Win64” -DCMAKE_INSTALL_PREFIX=C:\trinitycore -DCONF_DIR=/conf -DLIBSDIR=/lib -DMYSQL_LIBRARY=C:/MySQL/lib_64/libmysql.lib -DSERVERS=1

Is the line i came up and it fully compiles world and auth files.

Had some help tracking it down. It’s under MAIN.CPP files for both world and realm

Before Main.CPP




Removed the cfg_def_file due to it was not finding the normal conf paths.

has workaround you can use worldserver -c pathtoconfig.

Yep that would more than likely be easier the method i found seems to be working well tho with no issues other than having to add it every time compiling is done.

— Canned message start —
It appears the issue in the original post was solved, so this thread shall be closed.
Should you encounter any other difficulties, please open a new thread.
— Canned message end —