[SOLVED]CharacterCreating.Disabled Not Working

Settings such as CharacterCreating.Disabled and CharacterCreating.Disabled.RaceMask are not applying. I’m not sure if it is because I am misunderstanding but when I set these values it does not inhibit character creation.

For example my worldserver.conf


[/CODE]# CharacterCreating.Disabled.RaceMask
# Description: Mask of races which cannot be created by players.
# Example: 1536 - (1024 + 512, Blood Elf and Draenei races are disabled)
# Default: 0 - (Enabled, All races are allowed)
# 1 - (Disabled, Human)
# 2 - (Disabled, Orc)
# 4 - (Disabled, Dwarf)
# 8 - (Disabled, Night Elf)
# 16 - (Disabled, Undead)
# 32 - (Disabled, Tauren)
# 64 - (Disabled, Gnome)
# 128 - (Disabled, Troll)
# 512 - (Disabled, Blood Elf)
# 1024 - (Disabled, Draenei)

CharacterCreating.Disabled.RaceMask = 1536

I set it the same as in the example but I can still create both Blood Elf and Draenei characters.

Am I doing something wrong?

Did you try with a non GM account? If you tried with a normal account and it’s still possible to create those races, create a ticket in our tracker https://github.com/TrinityCore/TrinityCore/blob/6.x/CONTRIBUTING.md#issues

That was most definitely it, feeling like an utter dunce now! Non-GM Accounts working fine.

Glad to know :slight_smile:

— Canned message start —
It appears the issue in the original post was solved, so this thread shall be closed.
Should you encounter any other difficulties, please open a new thread.
— Canned message end —