[SOLVED]Incorrect file location on the How to Linux walkthru


Under the Configuring the server section of the How To Linux walkthru, it mentions the two config files to be located in the /home//server/etc/ folder.

Mine are in the /home//server/conf/ folder.

Not sure if that’s a typo or an issue with my install but I wanted to point that out.

Is it ok if I edit the wiki or should I stay away from doing so until I’m more familiar with the software? I don’t want to step on any toes so that’s why I’m reporting these instead of making the edits myself.



Without modify instalation path:

– Installing: /home/test/bin/testtrinity335a/etc/authserver.conf.dist

– Installing: /home/test/bin/testtrinity335a/bin/worldserver

Hmmm strange:

drmike@vps5:~$ cd server
drmike@vps5:~/server$ ls -la
total 20
drwxrwxr-x 5 drmike drmike 4096 Jul 18 08:54 .
drwxr-xr-x 6 drmike drmike 4096 Jul 18 23:06 …
drwxrwxr-x 2 drmike drmike 4096 Jul 18 22:56 bin
drwxrwxr-x 2 drmike drmike 4096 Jul 18 22:52 conf
drwxrwxr-x 5 drmike drmike 4096 Jul 18 09:08 data
No etc directory and both of the *.dist files are in the conf directory. Using Ubuntu for an OS.
If that’s how it is for you, it’s not a biggie for me. Just not seeing that.

Not really sure why that happens but the wiki could be edited to list both /etc and /conf

I realized on my walk come last night that the wiki uses the example of /conf :


cmake ../ -DPREFIX=/home/wow/server -DCONF_DIR=/home/wow/server/conf -DLIBSDIR=/home/wow/server/lib -DTOOLS=1 -DWITH_WARNINGS=1

even though a page down from there, it’s back to using /etc :

and the standard configuration files in the /home/<username>/server/etc folder.

Changed the example cmake command to use /etc instead of /conf.

— Canned message start —
It appears the issue in the original post was solved, so this thread shall be closed.
Should you encounter any other difficulties, please open a new thread.
— Canned message end —