[SOLVED][INVALID]SQL Error (1264): Out of range value for column

Hey, first of all, sorry if this is the wrong place for my question, i didn’t know where should i try to get help…

I’ve made a new NPC on my server (I’m using Jeutie’s Repack), i’ve made a new equipment in creature_equip_template, and when i’m trying to write my equipment id under the column “equipment_id” it always says:

SQL Error (1264): Out of range value for column ‘equipment_id’ at row 1

I tried to figure out what’s the max range value, and it looks like it’s 127. If i write 128 or more the error appears.

Any idea how can i fix it, or how can i change the max value?

I had already used Jeutie’s Repack - Trinitycore before a few years ago, and as I remember there was no problem like this at all…


— Canned message start —
Trinity does not support repacks.
Please learn to compile and configure the source yourself, you will learn more and may even find that the error doesnt exist in vanilla TC.
Please refer to the author of the repack for your questions if you continue to use said repack.
— Canned message end —

— Canned message start —
It appears the issue in the original post was solved, so this thread shall be closed.
Should you encounter any other difficulties, please open a new thread.
— Canned message end —