How can I open it? I tried dbcviewer but it has only old build column names, so it’s not working anymore. As I can understand you can manually add column name and types. It says “7 out of 8 columns” on “build 13205” option, and even less with others. I tried to add column, but looks like it needs proper name and type, that I don’t know where to get. Any help with this?


If not wrong, need VS 2015 for compile.

Figured out how to open MapDifficulty.db2 through DBC Veiwer, but swill dont know how to edit it.

Proper header types are: 0 - string 1-6 - int. Please let me know if you managed to edit db2 files.

You should not change db2 files, otherwise your kernel will simply not run.

If core not have this hotfixes support, need implement in core and you can change in hotfixes databases.

we don’t support client files modification, if you have “columns missing” error, update your core or your client.

— Canned message start —
It appears the issue in the original post was solved, so this thread shall be closed.
Should you encounter any other difficulties, please open a new thread.
— Canned message end —