[SOLVED]Starting items have question mark icons and can't be used

First time user here, running Windows 7 with the 3.3.5 branch. I am using what I believe to be the latest world database, 335.60_2015_11_07.

I am having an issue with the starting items. They all have the correct icons when they are equipped, but they have question mark icons when they are unequipped and put into bags. More importantly, these items also do not allow the use of abilities such as sinister strike (it says that a melee weapon must be equipped in the main hand) or hunters to attack with range, but it does increase the correct weapon skill (so daggers would improve when auto-attacking with these items).

If I buy or loot other items they behave as expected.

I’ve read through a lot of documentation and forum posts looking for what I did wrong and I’m not sure what it is / what I missed. This page (https://trinitycore.atlassian.net/wiki/display/tc/playercreateinfo_item) says the items come from [COLOR=rgb(51,51,51)]CharStartOutfit.dbc. I’ve verified that this file exists with my other dbc files. If anybody could point me in the right direction I’d really appreciate it.

EDIT: Currently downloading another client and going to see if the dbc files extracted from it play nice.

EDIT 2: It was a client problem. If anybody else happens to find the same client download I did maybe this post will be useful to you.

— Canned message start —
It appears the issue in the original post was solved, so this thread shall be closed.
Should you encounter any other difficulties, please open a new thread.
— Canned message end —