[Solved][TC 3.x] Guild Bank


I don’t know if this is an issue or an intended behavior, as I lack knowledge.

I created a server few weeks ago and at the moment, it’s up to date with this commit: https://github.com/TrinityCore/TrinityCore/commit/59ac77522347310deba77195e3b2c5d8552561e3

There’s not enough players right now on this server to create a guild the legit way, so I used the associated gm command to create it.

And as I now have a “veteran” playing with us, I discovered this “issue” (or is it?): only the guild master is granted “access” to the bank tab (at the bottom of the guild management panel).
And by access, I mean not only is everything allowed, but all the related options are also greyed and they cannot be altered.
But my real problem is: I cannot grant guild bank access to other ranks.

Can I fix this with few sql queries?

Edit: nevermind… fixed my own stupidity: you need to buy those tabs from the bank…

Can’t give you a direct answer to your question.

But maybe a hint: Do you know that you can change in the config the amount of needed petitions to 0 ?

So I never had to found a guild by gm commands and also never discovered some problems.

Yeah, the idea vaguely crossed my mind (just vaguely).
Thanks for reminding me! But after testing, it still doesn’t work

So I did more research and truth is, I’m stupid, I need to buy those tabs before being allowed to access the options.
Fixed then :slight_smile:

hehe :slight_smile: