[SOLVED]Worldserver.exe crashes loading scenarios on first run

Running worldserver.exe, built from master branch, for the first time after compiling. Running 64 bit under Windows Server 2012. Battle pet info loads and then scenarios start to load and I get the following error. I don’t recall ever seeing a step in the guide about setting a max allowed scenario query size. Did I miss something?

Loading battle pets info…
>> Loaded 2884 battle pet breeds.
>> Loaded 998 battle pet qualities.
Loading scenarios

D:\Trinity\src\server\game\Scenarios\ScenarioMgr.cpp:132 in ScenarioMgr::LoadDB2
ARIO_POI_QUERY_SIZE must be at least 43

I changed the scenariopackets.h entry for MAX_ALLOWED_SCENARIO_POI_QUERY_SIZE from 42 to 84, to see if that would help.

Now the worldserver.exe runs without crashing. Hopefully this change has no bad side effect later.

Loading scenarios
>> Loaded 194 instance scenario entries in 2 ms
Loading scenario poi data
>> Loaded 0 scenario POI definitions. DB table scenario_poi is empty.
World initialized in 5 minutes 13 seconds
TC>TrinityCore rev. 0d6320dfd393 2019-08-08 09:06:16 +0200 (master branch) (Win6
4, RelWithDebInfo, Static) (worldserver-daemon) ready…

Hey csanburn - I have the same Problem - but in my Linux setup there is no scenariopackets.h :frowning: any Idea ?

It looks like they’ve updated the source to increase the max poi to 50 now. I’m pulling down the latest source to recompile now. That should fix it without requiring manually modifying on our own.

— Canned message start —
It appears the issue in the original post was solved, so this thread shall be closed.
Should you encounter any other difficulties, please open a new thread.
— Canned message end —