TrinityCore Search Engine

The TrinityCore Search Engine is a web application built with AngularJS and Bootstrap which allows to search into the database and displays datas to the user into a friendly format.

It retrieves all datas querying the TrinityCore JSON RESTful API and can currently show datas about Items, NPCs, Quests, Loots, Vendors, etc…

Live demo here.

Any suggestions are welcome.


Released under AGPL license.


  • Tables are now sortable

  • Added new fields in template table of each sub page

  • Fixed money values display

  • Cool top loading bar

  • Corrected minor bugs

  • Several minor improvements

  • Added Spells (thanks Nayd)

As said, any other suggestions are welcome!


  • Fit with latest TrinityCore revision

  • Requires TrinityCore JSON API v0.5 or newer


  • Live demo updated to TDB 335.59

This is really awesome.

How would I go about including this in my own page, rather than being on its own? I’ve added:

To the page, as well as including the JS and CSS in the header, but it doensn’t load. It looks like the routes are the issue, but updating the /home route to the absolute path doesn’t change anything. I really don’t want to use an iFrame!

Cheers :slight_smile:

Check Keira2 :wink:

I was just about to download this, I’m guessing it uses this search engine to search for the items before creating the SQL?

Also, whats the reason for the limit? I’ve tried changing it to 3 characters, but it still doesn’t find anything if you type in “bag”, but “e bag” searches correctly.

Probably you are missing:

[COLOR= rgb(51, 51, 51)]<html[COLOR= rgb(51, 51, 51)] lang[COLOR= rgb(51, 51, 51)]=“en”[COLOR= rgb(51, 51, 51)] ng-app[COLOR= rgb(51, 51, 51)]=“engine”[COLOR= rgb(51, 51, 51)]>

Nope, the Search Engine and Keira2 are totally separated software, even if they both need the TC-JSON-API.

The reason of the limit is to avoid searches with too many results.

And if you want to change it, you have also to change the API, but it is easy:

I’ve changed the search limit and it works, thank you for that!

Regarding the search engine, I completely missed that. However, now it is just an infinite loading loop, trying to load /home/. There are no errors and I have tried changing the path to the full home path, but once again, nothing.

The search engine is located at /api/database/, but as long as I call the correct paths for the JS and CSS, it should work, correct? Here is the full code I have on my page:


Created by ShinDarth & Helias

Not sure if I am missing something obvious. Thank you for your help :slight_smile:

I think it can be interesting to use Search Engine like a wowhead tool.