Trouble with your Trinity Install / Starting / Login / Readme 1st / FAQs

If you are have trouble with Trinity there are a lot of people on the forum willing to give you help.

But don’t be an idiot! If you want help give the OS you are using, any patches you have added, the exact problem, etc.

Pick a decent topic title (you don’t pay if you make descriptive topics). [COLOR=rgb(39,42,52)]If you go to post a long log please use[COLOR=rgb(39,42,52)] to post your log.

If you expect people to help you have enough respect to give these people the info to help you not just a vague question.

Since this is a huge thread i suggest you to use search feature of your browser and start writing only some words of your problem, for example, if you get:
Used MySQL library version (5.5.38) does not match the version used to compile TrinityCore (5.6.28)
try to write only Used MySQL library version or does not match the version used to compile TrinityCore, if you can’t find try to reduce even more the amount of keywords.


Database install errors:

Database update errors:

Other Database issues:

Startup errors:

Core compilation errors:

Core compilation errors Part 2:

Cmake errors:

How to enable debug logs:

Features FAQ:

Extractor Issues:

Help TrinityCore Project:

Client Issues:

Permission issues:

Custom things:

Reporting a Bug:

Reporting a Bug Part 2:

Working with RBAC commands:

Working with RBAC commands Part 2:

Working with RBAC commands Part 3:

Manual Database Installation:

Core Requierements:

Login Into TrinityCore:

VERY IMPORTANT: on branch master check BattleNet.log on your client directory to find better the reason of your issues to connect.

VERY IMPORTANT2 : We recommend don’t use spaces on paths tools / deps can give strange errors if you use directories with spaces.

[SIZE=36px][COLOR=rgb(39,42,52)]Database install errors [/SIZE]

[SIZE=16px][COLOR=rgb(39,42,52)]Please note that the software called Navicat is NOT supported due to issues with how it handles SQL-files with “/* */”-style comments. We advise all users to stay well clear of this program unless they really are looking for issues.[/SIZE]

TCE00001 My core don’t starts i get:

[1146] Table ‘world.updates_include’ doesn’t exist
Your database structure is not up to date. Please make sure you’ve executed all
queries in the sql/updates folders.

Maybe you are updating one very ancient core and missed some sql, easy way is drop all your trinitycore databases (auth, character, hotfixes, world) and leave core to import the databases if you don’t care about data.
Another way can be create temporally the needed databases and allow core to import the sql files, then export the updates and updates_include tables from those databases and import them to your production core (be sure you have updated your databases to max before import the updates tables to your production core).
REMEMBER: core needs one user with create table/alter table/drop table permisions.

TCE00002 My core don’t starts i get:

2012-07-11 16:47:10 ERROR: DatabasePool world NOT opened. There were errors opening the MySQL connections. Check your SQLDriverLogFile for specific errors.
2012-07-11 16:47:10 ERROR: Cannot connect to world database;3306;trinity;trinity;world

Unknown column ‘level’ in ‘field list’

2012-07-03 23:01:12 ERROR:
E:TrinitysrcserversharedDatabaseMySQLConnection.cpp:531 in MySQLConnection::_HandleMySQLErrno FATAL ERROR:
Your database structure is not up to date. Please make sure you’ve executed all queries in the sql/updates folders.

This means DB structure was changed, you need to apply the sql files found at sql/updates (this also can mean you have updated your db structure but you forgot to install the updated core)
If you use the most updated master branch and you don’t have custom things DROP your world database and get the most updated TDB from GET TDB then apply the sql files found at sql/updates.
If you can’t or you don’t want to drop your world database or droping world database don’t fixes your problem enable SQLDriverLogFile on your worldserver.conf file.

If you get those errors whatever you are trying on world database, use to create a 2 files instalation system to be sure you don’t miss any sql file.
Under Linux you can use rgrep sql/updates/*.sql to see what file you miss.
Under Windows you can use notepad++ or ultraedit 32 to search the file you miss.
Anyway if you have world db structure problems, we sugest you to DROP world db and leave core to import the files, because maybe you have missed some.
TCE00003 My server don’t starts, i get:

>> Loaded 0 trinity strings. DB table `trinity_string` is empty.

This is because you forgot to import world database or you have enabled autoupdater but missed to put world database on the worldserver directory or imported travis world database instead proper database.

If you get "unknown column" or "unknown table" error it can be because 10 reasons:
1) You have cloned master repository (3.3.5a) and installed TDB, but you forgot to apply the files present on sql/updates/world you need to run those to properly start core.
2) You have updated your database, but you forgot to update your binary files, you usually can't run older cores with newer databases.
3) You have updated your core, but you forgot to update your database, you usually can't run older databases with newer cores. MOST COMMON CASE
4) You have download 4.3.4/6.x databases, but you cloned 3.3.5a repository you can't use 6.x/4.3.4 databases with 3.3.5a core.
NOTICE use one very high range to avoid to get your spawns/scripts deleted when a new TDB is released unless you drop the full DB when updating.
NOTICE2: if you don't drop your world database you will end with double spawns.
8) You are trying to use a custom patch and you forgot to apply the sql files for it or they don't exist.
9) You are trying to use one sql for another project or deprecated sql files.
10) You are trying to apply the same update 2 times.

[SIZE=36px][COLOR=rgb(39,42,52)]Database update errors [/SIZE]

I can’t apply some sql updates, i get duplicate column or column don’t exist

A very common mistake is to try to apply no needed sql files, for example, when you download TDB51 you have the following files:

TDB_full_335.51_2013_02_14.sql this means the TDB version is for wow 3.3.5a, it’s the 51th TDB version and released the year 2013, February day 14.
and here comes the most common error:


Those 2 files are named year 2013, January day 14 to year 2013 February day 14, what means this? this 2 files are UPDATES from TDB 50 to TDB 51, if you have downloaded TDB51 you DON’T need to run those, because you have already more updated db version.
Another very common error is to try to apply auth/character updates into a fresh downloaded core, the base files for auth/characters are updated every time they need to be updated and you don’t need to run them on new server install.

The same is valid for 4.3.4, if you get TDB 4.3.4-4 you don’t need updates_01, 02, 03.
TCE00004 I can’t start core, i have applied every update and i get: [1054] Unknown column ‘id’ in ‘field list’

You are running the updates 2 times, if you merge sql files you only need to run TDB sql files and merged sql.
TCE00005 I can’t start core, i get spelldifficulty_dbc: spell 71356 at field id:2108 at spellid0 does not exist in SpellStore (spell.dbc), loaded as 0 or similar

You forgot to apply some sql files you can fix this appling the correct 3.3.5a file on your database if you know what are you doing.
I can’t import some sql files, i get “Data too long for column ‘description_loc1’” or similar errors

Use mysql --default-character-set=utf8 -u username -pPASSWORD database < filename.sql to import your sql files. P.S. Seriously consider leave autoupdater to setup your core.
I can’t start core, i get:

Applying update “2017_10_27_01_world.sql” ‘BDDAB16’…
ERROR 1067 (42000) at line 181: Invalid default value for ‘start_time’
line is: ALTER TABLE game_event ADD COLUMN holidayStage TINYINT UNSIGNED NOT NULL DEFAULT ‘0’ AFTER holiday;
Or simmilar messages

wiki states you must disable mysql strict mode to run trinitycore server, read:

[SIZE=36px]Startup errors[/SIZE]

TCE00007 Core don’t starts i get:

2012-07-25 11:45:24 ERROR: Creature guid overflow!! Can't continue, shutting down server.
This means you have spawned to much custom creatures, drop your world database and import a clean TDB or delete any spawn over guid 1000000 or reguid your custom guids for a lower guid (never reguid all, you will have problems with TDB updates).

TCE00008 Core don’t starts i get:

dbc exists, and has 13 field(s) (expected 12). Extracted file might be from wrong client version or a database-update has been forgotten.
You need to extract the files from the same unmodified client version of the server you are trying to run, 

Core don’t starts it’s closes as son i click the icon

Use cmd to start the core instead the icon, on that way you can read the exact error, if you don't know what's cmd, stop trying to create a server or buy a windows book.

I can’t run Trinitycore on my AMD Athlon XP system

Indeed, you can't, you need SSE2 support to run Trinitycore.

TCE00009 Core don’t starts, i get: 0x000007b

You need mysql => 5.1.

TCE00010 I can’t run TrinityCore on my system i get “The ordinal 4334 Could not be located in the dynamic link library libeay32.dll found.”

Copy the dlls from openssl directory to where you put TrinityCore files.
TCE00011 I can’t run Trinitycore, i get Used MySQL library version (x.x.xx) does not match the version used to compile TrinityCore (x.x.xy)

On windows copy the dlls from your build directory to where you are running core. On linux you must recompile your core (you may need to delete build directory).
I get – Performing Test boost_filesystem_copy_links_without_NO_SCOPED_ENUM - Failed error

You can ignore it, it's a warning that we can't hide.

	[B]TCE00012 I can't run Trinitycore, i get  [COLOR=rgb(39,42,52)]instance().use_certificate_chain_file("bnetserver.cert.pem", err) failed: No such file or directory [/B]

You need to run trinitycore binaries from bin directory.

I can’t use any command, i get [COLOR=rgb(39,42,52)]Table command contains a non-existing command ‘deserter’, skipped. for any command i run.

You are using old style cmake, remove build directory and re-run cmake and be sure SCRIPTS or -DSCRIPTS have a value different to 0,1, the correct values are: none, static, dynamic, minimal-static, minmal-dynamic. The recommended setting to replace the old 0 is minimal-static.

TCE00018 I get error running server: [SIZE=16px][COLOR=rgb(0,0,0)]Map file ‘./maps/000433[COLOR=rgb(0,0,0)]’ is from an incompatible map version (MAPS v1.3), MAPS v1.8 is expected. [/SIZE]

Please pull your source, recompile tools, copy extractors to your wow binary directory (for example c:\games\World of Warcraft) and recreate maps using the updated mapextractor, then replace your old map files with new files. Be sure you compile the extractors for the correct version of you you are trying to use 1.3 don't means wow version 3 instead maps version 1.3

					f you have problems with core being unable to find dbc/maps/mmaps/vmaps files can be because you don't have extracted the files, or you have put them on incorrect directory, check the path for them, also, using absolute paths (c:pathtotrinitycoredbc_maps_mmaps_vmaps_files) can help you better than using relative paths.

[SIZE=36px][COLOR=rgb(39,42,52)]Core compilation errors [/SIZE]

I don’t get Trinitycore hash

Read Howto properly install git on Windows
I can’t compile Trinitycore under CentOS 5/FreeBSD 9.0/Ubuntu 16.04LTS/Debian 8

Trinitycore needs GCC 6.3 or higher, CentOS 5 users needs to update CentOS or install GCC 6.3.0 minimum (not for newbies) (better alternative install clang 3.5 minimum).
I can’t compile Trinitycore under Windows XP

Trinitycore needs Visual Studio 2017 you need to update to Windows 7 or higher.
I can’t compile Trinitycore under Linux i get [COLOR=rgb(0,0,205)]c++: internal compiler error: Segmentation fault (program cc1plus)

This can be because multiple reasons:

  1. Selinux stronged kernels, workaround change to one standard kernel or compile with clang instead gcc or compile without pch.
  2. Low ram/swap memory, increase ram/swap amount.
    how i do under linux?

If you don't know linux, buy a book, or use windows, running a server is not intended for ppl without knownledge on the OS they use.
[COLOR=rgb(39,42,52)]I can’t compile Trinitycore i get /usr/local/include/boost/utility/result_of.hpp:189:8: error: no class template named ‘result’ in ‘const struct TaxiPathGraph::GetCompleteNodeRoute(const TaxiNodesEntry*, const TaxiNodesEntry*, const Player*, std::vector&)::<lambda(const struct TaxiPathGraph::EdgeCost&)>’

Your boost version is to old, update minimum to 1.62, if you hand installed boost remember to remove apt-get installed/some other linux package tool installed version.
I can’t compile Trinitycore i get fatal error C1060: compiler is out of heap space
C1076: compiler limit : internal heap limit reached; use /Zm to specify a higher limit


[B]I can't compile Trinitycore i get [/B][B]fatal error C1001: An internal error has occurred in the compiler.[/B]

Update your Visual Studio.
I can’t compile Trinitycore i get Performing C++ SOURCE FILE Test boost_filesystem_copy_links_without_NO_SCOPED_ENUM failed with the following output:

It's a very bad idea to mix experimental packages on production servers, return to stable packages (if you can't install boost after this fuckup use aptitude).

[SIZE=36px][COLOR=rgb(39,42,52)]How to enable debug logs [/SIZE]

How i get good crashlogs under Linux?

Under linux compile with the following flags:

declare -x CFLAGS=“-m64 -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O0 -g3 -ggdb3 -pipe -msse3 -fno-strength-reduce -fno-delete-null-pointer-checks -fno-strict-aliasing -frename-registers -rdynamic”
declare -x CXXFLAGS=“-m64 -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O0 -g3 -ggdb3 -pipe -msse3 -fno-strength-reduce -fno-delete-null-pointer-checks -fno-strict-aliasing -frename-registers -rdynamic”
cmake …/ -DCMAKE_INSTALL_PREFIX=/change/path/to/trinity -DCMAKE_BUILD_TYPE=None

If your core lags to much change -O0 by -Og or even -O1.
Then copy TrinityCore/contrib/debugger/crashreport.gdb to your Trinitycore’s bin directory and create a file with the following lines and make it runable:

cp backtrace.log +%Y%m%d-%H%M%S.log
screen -A -m -d -S tri_world gdb -x crashreport.gdb ./worldserver -c …/etc/worldserver.conf

When your core crashes you will have a file called backtrace.log on your TrinityCore’s directory.
How i get good crashlogs under Windows?

Select the dropdown on compile mode and change from RelWithDebug to Debug, Release mode crashlogs are useless.

[SIZE=36px][COLOR=rgb(39,42,52)]Features FAQ [/SIZE]

Wintergrasp works?

ATM wintergrasp is WIP, there are a lot of bugs that needs to be fixed.
What instances/arenas/bgs are working?

Most of instances works on Triniycore, some are really blizzlike, others are fully broken, you can read about the status of some at (needs login to be seen)
On my bgs we have 10 vs 5 players making it easy mode for one faction.

You can enable Battleground.InvitationType = 1 on your worldserver.conf file.
Warden works?

Yes, it does, but it doesn't have 100% sucess rate, and some of the "hacks" it detects are malware, if you see any entry of warden that it's malware detection and you have one malwarebytes/adware scan post it at TrinityCore (warden doesn't detects all hacks, not even on retail)
How i can close one instance/bg?

How i can disable one spell?

Use disables system, read Disables

[SIZE=36px][COLOR=rgb(39,42,52)]Extractor Issues [/SIZE]

I am looking to extract maps but extractor is for wow 4.

No it's not, vmap4extractor/vmap4assembler means it's extractor for Vmaps Version 4, no Vmaps for wow 4.
TCE00013 I get MMAP:loadMap: 5303952.mmtile was built with generator v4, expected v5 constantly.

You are trying to use some old mmaps version, recompile tools with the updated source you are using and re-extract all again.
TCE00014 I get Couldn’t open RootWmo while running extractor.

It’s not real error, you can ignore it.

I can’t extract Vmaps

You need to extract maps 1st.

My mobs casts spells through walls

You need to extract and enable vmaps. Note: on some terrains mobs (and players) can cast through walls and it’s blizzlike.

My mobs walks through walls

For this you need mmaps, atm Trinitycore this feature is disabled by default (extraction can take hours). Enable it on config.

I used to use Mangos, can i reuse Maps/Vmaps/mmaps?

No, you can’t TC’s versions for maps,vmaps and mmapsare diferent.

TCE00015 I get error opening casc storage ‘C:/Program Files (x86)World Of WarcraftData’: UNKNOWN or [COLOR=rgb(82,82,82)]FILE_NOT_FOUND
Use repair to get missing files.
Be sure exist on your wow directory and you are running the extractor where your wow binary is located for example: C:\games\World of Warcraft
You may have used 6.x/7.x extractor trying to extract older wow version, you cannot use any extractor version with any wow version, the extractors belongs to especific wow versions.
Be sure you have wow binaries / bnet launcher closed.

TCE00017 I get error running map extractor, i get "[COLOR=rgb(39,42,52)]No locales detected "

Be sure you are running the extractor where your wow binary is located (for example: C:\games\World of Warcraft). Also, be sure you are running the correct version of wow for the selected branch.

I am unable to extract files on master, it’s stuck forever

Run your wow client and exit and re-run extractor

If you have crashes extracting maps on 4.3.4 branch can be because you have downloaded one incomplete client.
If you have crashes extracting maps on 6.x branch can be because you are trying to use one localized client, switch locales to enus to allow extraction.

If you cannot extract maps on master branch, be sure you have wow and bnet launcher closed, if that still fails change language to enus, if you are on enus change to another language and return to enus.

[SIZE=36px][COLOR=rgb(39,42,52)]Other Database issues [/SIZE]

From where i get the database?

Navicat gives error when trying to import TDB

Avoid to use Navicat to import TDB, it don’t follows all the sql standards and gives problem when trying to import files with /* */ or prepared statements.

Importing TDB is really slow

We recommend to use mysql cli to import TDB, it’s the faster way.

How i use mysql cli?

On linux computers:

mysql --default-character-set=utf8 -u USERNAME -pPASSWORD DATABASE < FILENAME.sql

On windows computers:

cd pathtomysql.exe

mysql --default-character-set=utf8 -u USERNAME -pPASSWORD DATABASE < PATHTOFILENAME.sql

Replace CAPS for the needed username, password, database and files.

There are to much sql files under sql/updates directory

Use and then follow the “How i use mysql cli” with the created file.

[SIZE=36px][COLOR=rgb(39,42,52)]Help TrinityCore Project [/SIZE]

What i can do to help Trinitycore?

If you know c++ or sql you can create patches or db fixes and post them at TrinityCore if you don’t know but you played on retail you can create good bug reports following the rules at The TrinityCore issuetracker and you

Trinitycore accepts donations?

No, Trinitycore doesn’t accept monetary donations, but you can donate good code or human labor /emoticons/default_tongue.png

What’s a sniff?

One sniff is the dump of the trafic of your network, with this system we can get the most Blizzlike core.

I have one sniff, where i can upload it?

You can upload your sniffs to this subforum is write only for users, so your private data will be safe.

I can’t see forum

This forum have a lot of subforums hidden for unregistered visitors, you need to register/login to have access to them.

I can’t see threads

Only devs can access sniffs, because they have private data, and this data can allow the ban of the characters used to sniff if this data become public.

Why you don’t push my pull request/fix?

We have a limited amount of devs and not every dev knows about everything so some fixes can wait for a long time, also devs can’t test everything alone, so ppl with testers must try some fixes before.

Also maybe you don’t follow TC’s coding standards, read

I have a fix, but i don’t know how to work with git.

You can use github, fork TrinityCore, make a branch for your fix (click branch button, write branch name), edit needed files and then make a pull request with it.

cmake errors

TCE00019 I can’t compile Trinitycore, i get [COLOR=rgb(39,42,52)]CMake Error at cmake/options.cmake:19 (message):[COLOR=rgb(39,42,52)] The value (1) of your SCRIPTS variable is invalid! Allowed values are:[COLOR=rgb(39,42,52)] none;static;dynamic;minimal-static;minimal-dynamic[COLOR=rgb(39,42,52)]Call Stack (most recent call first):[COLOR=rgb(39,42,52)] CMakeLists.txt:50 (include) or similar

You are trying to update your core from pre-hotswaping system to one hotswaping build or one outdated non-official wiki you need to delete your build directory and re-run cmake and be sure on a GUI you have a dropdown allowing to select between [COLOR=rgb(39,42,52)]none;static;dynamic;minimal-static;minimal-dynamic or on command line to use -DSCRIPTS= one of the values listed on the error message. If you are following one non-official wiki, the proper wiki is

TCE00020 TCE00021 I can’t compile Trinitycore, i get:

CMake Error at cmake/macros/FindBoost.cmake:1185 (message):
Unable to find the requested Boost libraries.

Boost version: 1.65.0

Boost include path: C:/boost_1_65_0

Could not find the following static Boost libraries:

or similar

Read point 7 of be sure if you use Visual Studio 2015 you get boost compiled for Visual Studio 2015 or if you use Visual Studio 2017 you get boost compiled for Visual Studio 2017.
Also, if you are updating Linux based Trinitycore you may miss new deps.

If you have installed both 32 and 64 bits versions delete boost and install only 64 bits versions and be sure you select 64 bits visual studio on cmake.

TCE00022 I can’t compile Trinitycore, i get:

CMake Error at cmake/macros/FindOpenSSL.cmake:226 (message):
TrinityCore needs OpenSSL version 1.0 but found too new version … Any
version different to 1.0.x breaks TrinityCore compatibility (and we cannot
fix this). Please install OpenSSL 1.0.x
Call Stack (most recent call first):
dep/openssl/CMakeLists.txt:16 (find_package)

World Of Warcraft client uses OpenSSL 1.0.x (yes, even on legion) this is a constant we cannot change, you need to install OpenSSL 1.0.1 or 1.0.2, if you run a linux system with OpenSSL 1.1 installed systemwide you will need to download OpenSSL 1.0.1/1.0.2 sources and compile yourself and tell CMake where your OpenSSL is installed (recomended to install it on a subdirectory on your home directory) with the use of the following switches:






Debian 9 and Fedora 26 ships by default with OpenSSL 1.1 read to known how to deal with it.

I get “Unknown compiler version - please run the configure tests and report the results” error while compiling.

It’s not error instead warning, try updating your boost revision, if with updated revision you still get the error, don’t worry, it’s not error instead minor warning and you can ignore it.

[SIZE=36px][COLOR=rgb(39,42,52)]Client Issues [/SIZE]

My wow 3.3.5a client tries to update when i try to login
Trinitycore uses usernames and not emails to login ingame, you must avoid the use of @ on your usernames/login secuence or your client will try to update to live version.

My wow 4.3.4 client tries to update when i try to login
Wow 4 clients tries to update to live version even if you enter a username at login, you must edit and set patchlist to localhost to avoid that.
You can get “Cannot stream required archive data. Please check the network connection” if you don’t have a full wow 4.3.4 client, you must download it from somewhere.

I get error [COLOR=rgb(51,51,51)]0xc000007b every time i try to start core

[COLOR=rgb(51,51,51)]This error is because you have mixing 32 and 64 bits libraries.

[SIZE=14px][COLOR=rgb(0,0,0)]I get failed to connect 5 times to world socket, aborting login on 6.x core[/SIZE]

You have forgot to open the 2nd 6.x port (8086 by default).

[SIZE=36px][COLOR=rgb(39,42,52)]Core compilation errors Part 2[/SIZE]

I am unable to compile i get

trinitycore/src/server/shared/Cryptography/OpenSSLCrypto.cpp:34: error: variable or field ‘threadIdCallback’ declared void

trinitycore/src/server/shared/Cryptography/OpenSSLCrypto.cpp:34: error: ‘CRYPTO_THREADID’ was not declared in this scope

trinitycore/src/server/shared/Cryptography/OpenSSLCrypto.cpp:34: error: ‘id’ was not declared in this scope

trinitycore/src/server/shared/Cryptography/OpenSSLCrypto.cpp: In function ‘void OpenSSLCrypto::threadsSetup()’:

trinitycore/src/server/shared/Cryptography/OpenSSLCrypto.cpp:46: error: ‘threadIdCallback’ was not declared in this scope

trinitycore/src/server/shared/Cryptography/OpenSSLCrypto.cpp:46: error: ‘CRYPTO_THREADID_set_callback’ was not declared in this scope

trinitycore/src/server/shared/Cryptography/OpenSSLCrypto.cpp: In function ‘void OpenSSLCrypto::threadsCleanup()’:

trinitycore/src/server/shared/Cryptography/OpenSSLCrypto.cpp:53: error: ‘CRYPTO_THREADID_set_callback’ was not declared in this scope

If you are using one linux with system wide openssl 0.9.8 instalation you need to update to openssl 1.0.0 or install openssl 1.0.0 into your home directory and set cmake to that path with:






I can’t compile TC under *NIX. i get: error: expected “)” before â_BUILD_DIRECTIVE""

Update your TC sources.

I can’t compile TC under Windows. i get:

The C compiler "C:/Program Files (x86)/Microsoft Visual Studio

10.0/VC/bin/x86_amd64/cl.exe" is not able to compile a simple test program.

Install any available service pack/update for your Visual Studio version.

I can’t compile TC under Windows. i get:

Could not find the MySQL libraries! Please install the development

libraries and headers

MySQL sources have been removed from the repository.

Like OpenSSL, you need to set MYSQL_LIBRARY and MYSQL_INCLUDE_DIR to where you have mysql installed.

In my case, it’s LIB=C:mysqlliblibmysqld.lib and INCLUDE_DIR=C:mysqlinclude

I can’t compile TC i get:

/usr/bin/ld: cannot find -lpthreads

undefined reference to `pthread_create’

declare -x CFLAGS=“-m64 -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O1 -g3 -ggdb3 -pipe -msse3 -fno-strength-reduce -fno-delete-null-pointer-checks -fno-strict-aliasing -frename-registers -rdynamic -fno-fast-math -lpthread”

declare -x CXXFLAGS=“-m64 -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O1 -g3 -ggdb3 -pipe -msse3 -fno-strength-reduce -fno-delete-null-pointer-checks -fno-strict-aliasing -frename-registers -rdynamic -fno-fast-math -lpthread”

cmake …/ -DCMAKE_BUILD_TYPE=None -DCMAKE_INSTALL_PREFIX=/your/installation/path

Another fix can be:

If you didn’t install mysql from an apt package like me, tc might not find you mysql client lib also if it says it has found it. “-DMYSQL_LIBRARY=/usr/lib/x86_64-linux-gnu/” will get it working

Thx Nikno.

[SIZE=36px][COLOR=rgb(39,42,52)]Permission issues [/SIZE]

I get when using account set gmlevel

SQL(p): INSERT INTO rbac_account_groups (accountId, groupId, realmId) VALUES (5, 1, -1)

[ERROR]: [1452] Cannot add or update a child row: a foreign key constraint fails (auth.rbac_account_groups, CONSTRAINT fk__rbac_account_groups__account FOREIGN KEY (accountId) REFERENCES account (id) ON DELETE CASCADE)

Unhandled MySQL errno 1452. Unexpected behaviour possible.

Run this sql on auth db:


[B]So I cannot use commands or anything in game with the newest trinitycore source.[/B]

My players can’t join bgs.

My players can’t join arenas.

My players can’t join lfd.

This “bug” is because you insert accounts directy on db instead using soap to create accounts.

To “fix” this “bug” you need to add player group into rbac_account_groups table or rewrite your php script to soap.

Can i delete RBAC system? Well, you “can” but future commits will add more RBAC things, and your work will be even more hard to revert it, since the plans are make the core fully RBAC based.

My players can run gm commands

You missed to import some commands at old/3.3.5a/TDB50_to_TDB51_updates/auth/ or you got error running them, maybe you need to run ALTER TABLE account ENGINE=InnoDB;

My gms can’t run gm commands

You imported incorrectly auth updates over a new base_auth.sql and you deleted your gm permissions.
Or you have hand created gm account into database, use account set gmlevel to give gm permissions.
NOTE: for 6.x branch the account name must come from accounts table not from if you have fresh installed wow 6 and created the account with bnet create, the account can be named something like 1#1.

[SIZE=36px][COLOR=rgb(39,42,52)]Custom things [/SIZE]

What’s a hack

On Trinitycore a hack is a bad way to fix something (ie hand spawn one mob somewhere because spawn spell doesn’t work) Also, changing WDB fields is a hack, never ever change one WDB field without a proper source (Sniff, retail cache)

How i apply a patch?

The best way is to use git apply /path/to/file.patch command if you get warnings you can simply ignore them, if you get error it will need to be updated. If you know a bit of coding you can use git apply /path/to/file.patch --reject and apply .rej code to the target files.

Don’t bump patch threads asking to update a patch, duplicate update patch posts/topics will be deleted/closed.

[SIZE=36px][COLOR=rgb(39,42,52)]Reporting a Bug [/SIZE]

How i report a bug

Use our bug tracker at github, read The TrinityCore issuetracker and you if it’s your 1st time reporting a bug.

Search on bug tracker before reporting a new bug, also don’t put multiple bugs on a single ticket. Duplicate tickets will be closed without warning or reason.

If one bug was fixed before and it bugs again open a new ticket. Don’t use screenshots to post crashlogs, learn how to copy and paste text from your system.

You also can copy text from ingame with the wow addon called Prat 3.0

Read the trinitycore issuetracker and you/ to post proper bug reports.

I made 3 topics about my bug and they are deleted/closed.

Making multiple topics about one thing don’t helps you to get faster answers, instead the oposite, they also can be merged to a existing topic of same question, search before posting.

I have send a PM to a dev asking to fix my bug but i don’t get answer!

Devs aren’t your private devs, if you have a bug, post it on bug trackers, if you send a pm to a dev is very likely to be ignored.

I have reported a bug months ago and it’s unfixed yet

Devs fixes what they know how to fix/they can fix, and they do on their sparse time. Asking to fix a bug multiple times don’t fixes them faster.

[SIZE=36px][COLOR=rgb(39,42,52)]Reporting a Bug Part 2 [/SIZE]

Consider whether or not the following alternatives apply to your problem before posting here:

[ul][li]For crashes or bugs during runtime, missing functionality, or patch submission, see the TrinityCore Issue Tracker. (Instructions here)[/li]
[li]If you have custom content to share, use Custom Code[/li]
[li]For issues related to components that are not yet implemented in the official Trinity Core/Database codebase, please see Code Development, and post in the appropriate subsection.[/li]
[li]For issues related to the website or forums, please see Website issues[/li]
[li]For issues related to Trinity Utilities, please see the respective thread in the Trinity Utilities section.[/li]
[li]For issues related to third-party services such as repacks, alternative databases, TrinityCore forks, please refer to the original authors.[/li]
First and foremost, you should use the forum’s Search Function to search for keywords on your issue, to see if your issue has already been addressed.

When posting a topic in this section, do your best to find a suiting title that summarizes your problem. A good descriptive title might make the difference between your issue being addressed or blatantly ignored. Avoid shreeks for attention such as “help plz”, “very important”, “wtf”, etc.

When posting one startup log or a big block of code use spoiler bbcode ( [ spoiler ] [ /spoiler ] ) without spaces.

As for the issue itself, post all available information you have to offer. Statistical information must contain at least:

[ul][li]Your Operating System[/li]
[li]Your TrinityCore Revision[/li]
[li]Your TrinityDatabase Version[/li] VERY IMPORTANT, WHY THERE IS NO LATEST: on github after 1 month we can’t known the date the issue was posted, and because that we can’t known the revision

Furthermore, avoid posting screen shots. Copy / Paste the relevant text and wrap it in quote tags instead. Most of the time, reading core output thoroughly before visiting this section gives you a clear indication of the problem, as the core’s output is decently verbose. If your core does not give you any noticeable output, try running it[B] via the command line /B. You can copy text from client with the wow addon Prat

Once your issue has been posted, refrain from unnecessary bumps and pestering the staff to look at your issue.

Please help us help you by following these steps.

Thank you.

– Trinity Team

[SIZE=36px][COLOR=rgb(39,42,52)]Working with [COLOR=rgb(39,42,52)]RBAC commands [/SIZE]

RBAC interesting commands

PVP based RBAC permisions

Stop a player from join battlegrounds (3), random battlegrounds (4) and arenas (5).

.rbac account permission deny 3 -1

.rbac account permission deny 4 -1

.rbac account permission deny 5 -1

Remove the deny of a player from join battlegrounds, random battlegrounds and arenas.

.rbac account permission revoke 3 -1

.rbac account permission revoke 4 -1

.rbac account permission revoke 5 -1

[SIZE=36px][COLOR=rgb(39,42,52)]Working with RBAC commands Part 2 [/SIZE]

Social based RBAC permisions Account limited

Allow a player instant logout (1),

to chat with other faction on say, yell, tell (25) or channels (26),

send mails (27),

see people of other factions on who (28),

add friends of other factions (29),

use whispers off (36),

Receive global GM messages/texts (44) (for example for player accounts of gms)

.rbac account permission grant 1 -1

.rbac account permission grant 25 -1

.rbac account permission grant 26 -1

.rbac account permission grant 27 -1

.rbac account permission grant 28 -1

.rbac account permission grant 29 -1

.rbac account permission grant 36 -1

.rbac account permission grant 44 -1

Deny a player the permisions.

.rbac account permission deny 1 -1

.rbac account permission deny 25 -1

.rbac account permission deny 26 -1

.rbac account permission deny 27 -1

.rbac account permission deny 28 -1

.rbac account permission deny 29 -1

.rbac account permission deny 36 -1

.rbac account permission deny 44 -1

Revoke a player the permision/restrictions

.rbac account permission revoke 1 -1

.rbac account permission revoke 25 -1

.rbac account permission revoke 26 -1

.rbac account permission revoke 27 -1

.rbac account permission revoke 28 -1

.rbac account permission revoke 29 -1

.rbac account permission revoke 36 -1

.rbac account permission revoke 44 -1

[SIZE=36px][COLOR=rgb(39,42,52)]Working with custom RBAC commands Part 3[/SIZE]

Social based RBAC permisions for all player accounts (this allows old .conf based permisions)

RBAC new style

INSERT INTO rbac_linked_permissions (id, linkedId) VALUES (195, 27); – Two side mail interaction

INSERT INTO rbac_linked_permissions (id, linkedId) VALUES (195, 25); – Say chat between factions

INSERT INTO rbac_linked_permissions (id, linkedId) VALUES (195, 36); – Allow to use whispers off

INSERT INTO rbac_linked_permissions (id, linkedId) VALUES (195, 26); – Channel chat between factions

INSERT INTO rbac_linked_permissions (id, linkedId) VALUES (195, 24); – Two side faction characters on the same account

INSERT INTO rbac_linked_permissions (id, linkedId) VALUES (195, 28); – See two side who list

INSERT INTO rbac_linked_permissions (id, linkedId) VALUES (195, 29); – Add friends of other faction