TrinityCore Extracting

TrinityCore rev. 1af6df41a5e3 2017-10-02 15:42:58 +0200 (3.3.5 branch) (Win64, Release, Static) (worldserver-daemon)
to stop.

/\__  _\       __          __/\ \__
\/_/\ \/ _ __ /\_\    ___ /\_\ \, _\  __  __
   \ \ \/\`'__\/\ \ /' _ `\/\ \ \ \/ /\ \/\ \
    \ \ \ \ \/ \ \ \/\ \/\ \ \ \ \ \_\ \ \_\ \
     \ \_\ \_\  \ \_\ \_\ \_\ \_\ \__\\/`____ \
      \/_/\/_/   \/_/\/_/\/_/\/_/\/__/ `/___/> \
                                 C O R E  /\___/ /__/

Using configuration file C:/TrinityCore/Source/bin/Release/worldserver.conf.
Using SSL version: OpenSSL 1.0.2l 25 May 2017 (library: OpenSSL 1.0.2l 25 May 2017)
Using Boost version: 1.63.0
Updating Auth database…
>> Auth database is up-to-date! Containing 8 new and 19 archived updates.
Updating Character database…
>> Character database is up-to-date! Containing 1 new and 22 archived updates.
Updating World database…
>> World database is up-to-date! Containing 347 new and 2303 archived updates.
Realm running as realm ID 1
Using World DB: TDB 335.63
Will clear logs table of entries older than 1209600 seconds every 10 minutes.
Client cache version set to: 63
Using DataDir ./
WORLD: MMap data directory is: ./mmaps
VMap support included. LineOfSight: 1, getHeight: 1, indoorCheck: 1
VMap data directory is: ./vmaps
VMap file ‘./vmaps/000.vmtree’ does not exist
Please place VMAP files (*.vmtree and *.vmtile) in the vmap directory (./vmaps/), or correct the DataDir setting in your worldserver.conf file.
Unable to load critical files - server shutting down !!!

Hello before I start this thread I would like to tell you that my english is not that good and I’ve been looking everywhere on forums for help. As u can see I have the file “/vmaps/000.vmtree”, but still I get error trying 2 launch wowserver.exe



If this topic gets deleted. Pls tell me why at least even tho that you’re busy!

If it gets deleted, it’s probably because you are not using the official extractors for that version. The “[FONT=‘Courier New’]VMap file ‘./vmaps/000.vmtree’ does not exist[/FONT]” also means it can’t read the file, due to unsupported version.

You have to extract them fresh from what you compiled. Do NOT download and use unsupported mmaps, dbcs, or vmaps from another source.

hmmm, I am sure that I havent used any unsupported versions. Could it be the order that I am extracting to?

I start of copy → paste
vmap4extractor to C:\Users\Christopher\Desktop\Wrath of the Lich King 3.3.5a (wod models)
Then I start of launching mapexstractor
Then I have (DBC, Cameras and maps)
and then what?

There is no support to modify client, wod models change some dbc files, that probably is the cause of your error. Try to extract from original client 3.3.5 without any modifications. Also with that modification you get a lot of exception from your client when you try to reach an area that its not complete in your dbc.

Hello HannibalRoG!
I don’t think it’s the wod model who is causing the problem. But I will try with Dalaran-WoW’s client instead!
Yesteday I made a discovery. I gave up since Vmaps couldnt work correctly, so I downloaded Jeutie’s Repack instead. btw, I had no problem earlier this weak installing and setup Jeuties Repack but when I tried 2 run Worldserver it gave me the exact same error as my first post on this thread did. Even tho that I downloaded JEuties: (DBC, Vmaps, Mmaps, etc). So this night I’ve been resetting my whole computer, and I am trying again now to compile the server. :slight_smile:

@Chrisseria2520 As long as you do not use the original client without any modification and the tools that are compiled with the core you will still have problems extracting the datas and running the server

BTW who is dedicated to giving bad reputation in the post where it is trying to help people?
Poor unfortunate.

Hello @HannibalRoG. I havent been giving u bad reputation. I do really appreciate that you’re at least trying to help me! But I got one I see.
Well Hannibal you’re talking about the “original Client”, where can I be sure that I find the “original client” without any mods involved?

Maybe here you can download full client

I gave you credit :slight_smile: , I don’t normally touch credit thingy, however, extracting from a corrupt or broken client is actually pretty common.

Good catch!

@HannibalRoG and @CDawg, well have u guys ever been compiling ur own Trinitycore? I mean what version of different programs do u use? I just want 2 make sure, that I am not using some kind of wrong version or something?

If you follow all steep here you must be able to run the server without major problems, assuming you have an unmodified client and using the tools compiled with the server. Just follow the instructions and you will not have problems.

I thougth the same, so weird. +credit for helping people :wink:

I use Linux, and compile and extract 3.3.5a. (Ubuntu Server 16.04).

Like I said before, this really isn’t a “version” issue. If you compiled TC (3.3.5a), the issue is with your client asset extraction.

Not making any assumptions on the OP, but with my experience, most of the time it’s an OP that doesn’t like the answer, even if it’s the right one. :smiley:

@CDawg sorry, what its an OP.

@CDawg and @HannibalRoG

I would also like 2 know what’s an OP? Operator?

Anyway, you guys seems 2 be very helpful and friendly which I do appreciate! Furthermore, I would like 2 know the difference of TrinityCore Repack and a self-compiled server of Trinitycore? Do I have any benefits compiling my own server? Why I am asking is cus after days of work, I must admit that I am simple not good enough 2 make my own compiled server, I do not have the knowledge yet... Also, back in the days had my own TrinityCore Repack up and running and even my online friends could come join. I think we were like 10 people online raiding Naxx. But a guy was able 2 put on cheat and TrinityCore's anticheat was not able 2 detect him cheating.

Original poster

A repack is where you wont get support. It’s a pre-comiled server package for people that are incompetent on building their own server. You get no updates, you can’t fix core problems, and most of the time they are extremely outdated with so many bugs locked into a pre-compiled core that you have to deal with.

@Chrisseria2520 You said it best… You just explained that you had a negative experience with a repack (one of the largest) You had a guy that was able to cheat and hack your “repack” and there wasn’t a single thing that you could do, due to someone else that created the server in a package nad not able to add special detection and core functions within a repack.

Look… People are lazy, i’m not saying you are. But don’t let one small issue you run into block you from giving up. It’s very very while worth it to compile your own server. Not only can you make custom modifications and keep your package up to date, but you will learn a lot from it and have the confidence to tell your friends that you may be able to fix a certain issue - since you will get support.

@CDawg you’re wise I see. Maybe I am lazy I don’t know. I am just stuck after stuck. First I was able 2 get through Git Extensions, Cmake, Visual Studio and I was so far that I could even launch my self-compiled server just without Vmaps activated as this thread was all about. I thought that … how do I explain this, but I thought that my computer got confused somehow of all the time I re-installed the repack and re-installed different kind of versions of programs that my computer just needed a reset, so I did a fully reset on my computer. After that I installed everything again (Git Extensions, Cmake, Visual Studio, OpenSSL HeidiSQL, Navicat and even more), I am just stuck at Cmake. I installed HeidiSLQ version 5.5, Cmake 3.9.4 and Visual Studio 2015 Community, and for some reason I am just stuck there now.

I will try once again tomorrow since I would love to get this compiled server up and running.

I would like 2 hear what kind of versions u guys use of Cmake and Visual Studio

In your screenshots I see that you are using english in your OS so I guess that you dont know spanish but just in case that you do it, a video-guide in spanish Installing software requerided

I guess that you should to check the guide in the trinity wiki, you have everything that you need there,include the versions for every software need (HannibalRog gave you the link up).